
3D Scientific Visualization with Blender
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Blender

● 3D creation suite
● Modeling
● Rigging
● Animation
● Simulation
● Rendering
● Compositing and 

motion tracking
● Video editing

● API for Python scripting
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CONTENTS

● Blender installation

● Creating a 3D model of a molecule SF
6
 in Blender.
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                       INSTALLATION
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                       INSTALLATION
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                     INITIAL SETUP

Open User Preferences:

 File > User Preferences...



7

                     INITIAL SETUP

1.Select Input Tab

2.Under Presets select “Maya”

3.Save User Settings
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                     INITIAL SETUP

1.Select Cube and delete it (press Delete or X, or in 3D View 
Panel>Object>Delete...X). Confirm the dialog.

2.To Select object left-click it

3.To deselect, in 3D View Panel>Select>(De)Select All A
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                     INITIAL SETUP

1.Select Light, called Lamp

2.In the Properties Panel, set Lamp 
Type to Hemi.

1.Select Light, called Lamp

2.In the Properties Panel, set Lamp 
Type to Hemi.
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                     INITIAL SETUP

1.Place 3D cursor to the 0,0,0

2.Open the Properties Panel By pressing N, 
or in 3D View Panel>View>Properties

3.Find the block which is called 3D Cursor, 
and set location to 0,0,0.
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Creating a Camera Target

1.Create Empty.

2.Type: Plain Axes

3.Radius 2.000

4.Location (0, 0, 0)

5.In the Outliner             Panel, right click on the “Empty” 
object and Click Rename in the appeared menu. 

6.Rename it to CameraTarget:
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Creating a Camera Target
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             Linking the Camera with the Camera Target

1.Relocate and rotate the camera so it should “look” 
right at the CameraTarget:                                  
Location (0,-6,0), Rotation(90,0,0)

2.Select the Camera first then holding “Shift”, select the 
CameraTarget object.

3.Create relation – so that the camera always looks at 
the CameraTarget object. Object>Track>Track to 
Constraint

4.Save as startup. Now this scene will always open with 
a Camera, a CameraTarget and a light source
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             Linking the Camera with the Camera Target
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             Saving the scene as a startup file

 

Save the out scene as a 
Startup File:

 File > Save Startup File
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Prepare drafts and references

 1.Draw 3D model on the paper

2.Search for the similar images on the internet 

3.Divide it into the primitive objects: cube, sphere etc

4.Find identical parts of the object

5.Be creative, develop your own strategy
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Creating the first 3D model

1. Create Cylinder 

2. Set Radius to 0.5

3. Set Depth to 8 

*you won’t be able to change those values in that 
menu after the object is created and deselected. Don’t 
worry, there is another way of changing the shape

4. Create Ico Sphere

5. Set property: Subdivisions 4

6. Set property: Size 1.0

7. Translate it to (0, 0, 4) 
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Creating the first 3D model
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Duplicating the sphere object

1. In Tools tab, click Duplicate

2.Right click to drop duplicated sphere

* The duplicated object is dropped to the same 
location as the original.

3. In Properties panel, find Transform > Location > Z

4. Set Z value to -4 
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Duplicating the sphere object
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Editing mesh

1.Select the Cylinder and open the [Edit mode] (press Tab) 

2.Deselect all, by pressing ‘A’; or Via Menu: Select > 
(De)select All A

3.Make sure that your selection will not be limited to visible

4.Choose [Edge Select] Mode

5.Select vertical Edges: Press Ctrl + RightClick & Drag 
around the edges. (Select only vertical edges) 
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Duplicating the sphere object
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Editing mesh: subdividing edges

Select Subdivide:
 
Select Subdivide:
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Editing mesh: subdividing edges

1.Deselect all, by pressing ‘A’; or Via Menu: Select > 
(De)select All A

2.Perform the same actions with the top & bottom 
vertical edges:

 (Select only vertical edges) 

3.Deselect all

2.1. Select them 
2.2. Then Subdivide.
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Editing mesh: subdividing edges
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Joining objects in one mesh

1.Change to [Object Mode]

2.Select all three objects: cylinder and two spheres. 
Select by holding Shift and Left clicking each object

3.Join objects into one mesh: Object > Join
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Joining objects in one mesh
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Joining objects in one mesh

1.Change to [Object Mode]

2.Select all three objects: cylinder and two spheres. 
Select by holding Shift and Left clicking each object

3.Join objects into one mesh: Object > Join
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Assigning a material to the object 

1.Open the Material tab. 

2.Create new Material, by tapping New
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Assigning a material to the object 

Change the Diffuse color to RedChange the Diffuse color to Red



31

Assigning a material to polygons/faces

1.Change to the [Edit Mode]  by pressing Tab

2.Choose [Face Select] mode

3.Select the Top and the Bottom parts of the 
object. Ctrl + Right Mouse Btn, & drag around 

1.Change to the [Edit Mode]  by pressing Tab

2.Choose [Face Select] mode

3.Select the Top and the Bottom parts of the 
object. Ctrl + Right Mouse Btn, & drag around 
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Assigning a material to polygons/faces

1.In the Material Tab, add new material slot

2.Create a new Material

3.Assign that new material to the selection

1.In the Material Tab, add new material slot

2.Create a new Material

3.Assign that new material to the selection
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Assigning a material to polygons/faces
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Shading

1.Deselect all selected by pressing ‘A’

2.Select all faces of the mesh by pressing ‘A’

3.On the left, open Shading/UVs tab

4.Under Faces: select Smooth
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Shading

1.Open object’s Data Tab

2.Check Auto Smooth

3.Set Angle to 45 degrees

1.Open object’s Data Tab

2.Check Auto Smooth

3.Set Angle to 45 degrees
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Shading

Change back to [Object mode] 
(press Tab)
Change back to [Object mode] 
(press Tab)
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Shading

Change back to [Object mode] 
(press Tab)
Change back to [Object mode] 
(press Tab)
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Update object’s origin

1.Set 3D cursor to 0,0,0 

2.Select our model, and open Tool tab in 
the left panel

3.Select Set Origin then 

4.Origin to 3D Cursor
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Update object’s origin
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Duplicating the object

Make sure the object is selected, then Duplicate it. 

Right-click to drop the duplicated object to the same location as 

the original one. 

Make sure the object is selected, then Duplicate it. 

Right-click to drop the duplicated object to the same location as 

the original one. 
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Duplicating the object

Rotate that object 90 degrees CW around Y axis. 

Make sure the object is at location (0, 0, 0)

Rotate that object 90 degrees CW around Y axis. 

Make sure the object is at location (0, 0, 0)
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Duplicating the object

1.Select the rotated object and again duplicate it. 
Right-click to drop the duplicated object.

2.Rotate the object 90 degrees CW around X 
axis

1.Select the rotated object and again duplicate it. 
Right-click to drop the duplicated object.

2.Rotate the object 90 degrees CW around X 
axis
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Editor Areas

1.Hold and drag the corner to clone the 
Editor Area

2.Each Editor Area, can be configured to 
display different controls

1.Hold and drag the corner to clone the 
Editor Area

2.Each Editor Area, can be configured to 
display different controls
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Editor Areas

1.To Close the Area, move the pointer to 
the edge then right-click to see the menu

2.Select Join Area

3.Select the Area to be joined (closed)
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Setting up the Virtual Camera

Change the view-port of the top area to 

Camera view: View > Camera 

Change the view-port of the top area to 

Camera view: View > Camera 
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Setting up the Virtual Camera

1.Drag the camera along the Axes XYZ. 

2.Holding Left Ctrl while dragging snaps 
camera’s location to the grid
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Setting up the Virtual Camera

1.Move the Camera around the scene until the 
object appear inside 2/3 of the camera view.

2.Use Translate tab to enter the exact location 
you want your camera to be placed at.

3.The Camera has its own properties and one of 
them is a Focal Lens

4.Relocate the camera and adjust the Focal 
Lens property
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Setting up the Virtual Camera
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Rendering

To render the model, press F12. 

To close render preview, press ESC

To render the model, press F12. 

To close render preview, press ESC
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Rendering

To produce an image with transparent 
background follow the steps below:

1.Open Render Settings tab on the right

2.Select Shading tab

3.For Alpha choose Transparent

4.Then Open Output Tab

5.Choose file format PNG

6.RGBA, 

7.Compression 100% (for Quality): 
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Rendering

Press F12 to render: 
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Final steps

1.Select all objects: Holding Shift, left-
click each object.

2.Join selected objects into one mesh.

1.Select all objects: Holding Shift, left-
click each object.

2.Join selected objects into one mesh.
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Final steps

1.Change to [Edit Mode]

2.Open Create Tab on the left and Create Ico Sphere

3.Open Shading/UVs Tab on the left 

4.Under “Faces” choose Smooth

5.On the right panel choose Object Data tab

6.Check Auto Smooth

7.Set Angle to 45 degrees
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Final steps
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Final steps

1.Open Material tab

2.Choose the existing Red 
colored material form the list. 

3.Assign it to the selected Sphere

1.Open Material tab

2.Choose the existing Red 
colored material form the list. 

3.Assign it to the selected Sphere
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Rendering

1.Press F12 To render.

2.Save rendered image:                        
UV/Image Editor, Image > Save as Image 

1.Press F12 To render.

2.Save rendered image:                        
UV/Image Editor, Image > Save as Image 
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Production Rendering

In the World tab update settings to the following values:
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Production Rendering

Update red material:
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Production Rendering

Update white material:
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Production Rendering

Update red material:
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Production Rendering
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Production Rendering
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